<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7 no-js" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8 no-js" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html class="no-js" lang="en-US">
<!--<![endif]-->
					<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://thishosting.rocks/xmlrpc.php">
<!-- html5shiv for IE8 and less  --><!--[if lt IE 9]>
				      <script src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/html5.js"></script>
				    <![endif]--><script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script><title>Comparing Elasticsearch with Solr – ThisHosting.Rocks</title>
<script>function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script><script type="text/javascript">var theChampCloseIconPath = 'https://thishosting.rocks/wp-content/plugins/super-socializer/images/close.png';</script><script> var theChampSiteUrl = 'https://thishosting.rocks', theChampVerified = 0, theChampEmailPopup = 0; </script><script> var theChampSharingAjaxUrl = 'https://thishosting.rocks/wp-admin/admin-ajax.php', heateorSsUrlCountFetched = [], heateorSsSharesText = 'Shares', heateorSsShareText = 'Share', theChampPluginIconPath = 'https://thishosting.rocks/wp-content/plugins/super-socializer/images/logo.png', theChampHorizontalSharingCountEnable = 0, theChampVerticalSharingCountEnable = 0, theChampSharingOffset = -10, theChampCounterOffset = -10, theChampMobileStickySharingEnabled = 0;var heateorSsCopyLinkMessage = "Link copied.";
				</script><style type="text/css">
	.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}	</style>
<meta name="robots" content="noydir">
<meta name="description" content="Comparing Elasticsearch with Solr – Solr and Elasticsearch have emerged as the two leaders of open source search engines. While both have one thing in common, Lucene, they have plenty of differences. Because of this, one may be a better choice than the other. That depends largely on what your intended…">
<meta property="og:image" content="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg">
<meta property="og:image:width" content="1170">
<meta property="og:image:height" content="500">
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Comparing Elasticsearch with Solr – ThisHosting.Rocks">
<meta property="og:description" content="Solr and Elasticsearch have emerged as the two leaders of open source search engines. While both have one thing in common, Lucene, they have plenty of differences. Because of this, one may be a better…">
<meta property="og:url" content="https://thishosting.rocks/comparing-elasticsearch-with-solr/">
<meta property="og:site_name" content="ThisHosting.Rocks">
<meta property="article:publisher" content="https://www.facebook.com/thishosting.rocks">
<meta property="article:author" content="https://www.facebook.com/thishosting.rocks">
<meta property="fb:app_id" content="592468017630007">
<meta property="article:published_time" content="2018-02-22">
<meta property="article:modified_time" content="2018-02-22">
<meta property="og:updated_time" content="2018-02-22">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@thishostrocks">
<meta name="twitter:creator" content="@thishostrocks">
<meta name="twitter:title" content="Comparing Elasticsearch with Solr – ThisHosting.Rocks">
<meta name="twitter:description" content="Solr and Elasticsearch have emerged as the two leaders of open source search engines. While both have one thing in common, Lucene, they have plenty of differences. Because of this, one may be a better…">
<meta name="twitter:image" content="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg">
<meta name="twitter:image:width" content="1170">
<meta name="twitter:image:height" content="500">
<link rel="canonical" href="https://thishosting.rocks/comparing-elasticsearch-with-solr/">
<script type="application/ld+json">{"@context":"http://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://thishosting.rocks/","name":"ThisHosting.Rocks"}},{"@type":"ListItem","position":2,"item":{"@id":"https://thishosting.rocks/category/knowledgebase/","name":"Knowledgebase"}},{"@type":"ListItem","position":3,"item":{"name":"Comparing Elasticsearch with Solr","image":"https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg"}}]}</script><script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://thishosting.rocks/comparing-elasticsearch-with-solr/"},"headline":"Comparing Elasticsearch with Solr","image":{"@type":"ImageObject","url":"https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg","height":500,"width":1170},"datePublished":"2018-02-22T20:29:14+01:00","dateModified":"2018-02-22T20:30:50+01:00","author":{"@type":"Person","name":"ThisHosting.Rocks"},"publisher":{"@type":"Organization","name":"ThisHosting.Rocks","logo":{"@type":"ImageObject","url":"https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-60x60.png","width":60,"height":60}},"description":"Comparing Elasticsearch with Solr &#8211; Solr and Elasticsearch have emerged as the two leaders of open source search engines. While both have one thing in common, Lucene, they have plenty of differences. Because of this, one may be a better choice than the other. That depends largely on what your intended&#8230;"}</script><link rel="amphtml" href="https://thishosting.rocks/comparing-elasticsearch-with-solr/amp/">
<link rel="dns-prefetch" href="//s0.wp.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="alternate" type="application/rss+xml" title="ThisHosting.Rocks » Feed" href="https://thishosting.rocks/feed/">
<link rel="alternate" type="application/rss+xml" title="ThisHosting.Rocks » Comments Feed" href="https://thishosting.rocks/comments/feed/">
<link rel="alternate" type="application/rss+xml" title="ThisHosting.Rocks » Comparing Elasticsearch with Solr Comments Feed" href="https://thishosting.rocks/comparing-elasticsearch-with-solr/feed/">
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thishosting.rocks\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style type="text/css">
	.tablepress thead th div { float:left; }
</style>
<link rel="stylesheet" id="tc-gfonts-css" href="//fonts.googleapis.com/css?family=Raleway%7CRaleway" type="text/css" media="all">
<link rel="stylesheet" id="contact-form-7-css" href="https://thishosting.rocks/wp-content/plugins/contact-form-7/includes/css/styles.css" type="text/css" media="all">
<link rel="stylesheet" id="customizr-fa-css" href="https://thishosting.rocks/wp-content/themes/customizr/assets/shared/fonts/fa/css/fontawesome-all.min.css" type="text/css" media="all">
<link rel="stylesheet" id="customizr-common-css" href="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/css/tc_common.min.css" type="text/css" media="all">
<link rel="stylesheet" id="customizr-skin-css" href="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/css/blue.min.css" type="text/css" media="all">
<style id="customizr-skin-inline-css" type="text/css">

                  .site-title,.site-description,h1,h2,h3,.tc-dropcap {
                    font-family : 'Raleway';
                    font-weight : inherit;
                  }

                  body,.navbar .nav>li>a {
                    font-family : 'Raleway';
                    font-weight : inherit;
                  }

            body,.navbar .nav>li>a {
              font-size : 16px;
              line-height : 1.6em;
            }
table { border-collapse: separate; }
                           body table { border-collapse: collapse; }
                          
.social-links .social-icon:before { content: none } 
header.tc-header {border-top: none;}

.sticky-enabled .tc-shrink-on .site-logo img {
    					height:30px!important;width:auto!important
    				}

    				.sticky-enabled .tc-shrink-on .brand .site-title {
    					font-size:0.6em;opacity:0.8;line-height:1.2em
    				}

.tc-single-post-thumbnail-wrapper .tc-rectangular-thumb {
          max-height: 300px;
          height :300px
        }

        .tc-center-images .tc-single-post-thumbnail-wrapper .tc-rectangular-thumb img {
          opacity : 0;
          -webkit-transition: opacity .5s ease-in-out;
          -moz-transition: opacity .5s ease-in-out;
          -ms-transition: opacity .5s ease-in-out;
          -o-transition: opacity .5s ease-in-out;
          transition: opacity .5s ease-in-out;
        }

.tc-slider-loader-wrapper{ display:none }
html.js .tc-slider-loader-wrapper { display: block }.no-csstransforms3d .tc-slider-loader-wrapper .tc-img-gif-loader {
                                                background: url('https://thishosting.rocks/wp-content/themes/customizr/assets/front/img/slider-loader.gif') no-repeat center center;
                                         }.tc-slider-loader-wrapper .tc-css-loader > div { border-color:#08c; }
#tc-push-footer { display: none; visibility: hidden; }
         .tc-sticky-footer #tc-push-footer.sticky-footer-enabled { display: block; }
        

</style>
<link rel="stylesheet" id="customizr-style-css" href="https://thishosting.rocks/wp-content/themes/thishostingrocks/style.css" type="text/css" media="all">
<link rel="stylesheet" id="fancyboxcss-css" href="https://thishosting.rocks/wp-content/themes/customizr/assets/front/js/libs/fancybox/jquery.fancybox-1.3.4.min.css" type="text/css" media="all">
<link rel="stylesheet" id="the_champ_frontend_css-css" href="https://thishosting.rocks/wp-content/plugins/super-socializer/css/front.css" type="text/css" media="all">
<link rel="stylesheet" id="the_champ_sharing_default_svg-css" href="https://thishosting.rocks/wp-content/plugins/super-socializer/css/share-svg.css" type="text/css" media="all">
<link rel="stylesheet" id="tablepress-default-css" href="https://thishosting.rocks/wp-content/tablepress-combined.min.css" type="text/css" media="all">
<link rel="stylesheet" id="footable-core-min-css" href="https://thishosting.rocks/wp-content/plugins/footable/css/footable.core.min.css" type="text/css" media="all">
<link rel="stylesheet" id="footable-metro-min-css" href="https://thishosting.rocks/wp-content/plugins/footable/css/footable.metro.min.css" type="text/css" media="all">
<link rel="stylesheet" id="jetpack_css-css" href="https://thishosting.rocks/wp-content/plugins/jetpack/css/jetpack.css" type="text/css" media="all">
<script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/jquery.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/jquery-migrate.min.js"></script><script type="text/javascript">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</script><script type="text/javascript">
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/assets/front/js/libs/fancybox/jquery.fancybox-1.3.4.min.js"></script><script type="text/javascript">
/* <![CDATA[ */
var TCParams = {"_disabled":[],"FancyBoxState":"1","FancyBoxAutoscale":"1","SliderName":"","SliderDelay":"","SliderHover":"1","centerSliderImg":"1","SmoothScroll":{"Enabled":false,"Options":{"touchpadSupport":false}},"anchorSmoothScroll":"easeOutExpo","anchorSmoothScrollExclude":{"simple":["[class*=edd]",".tc-carousel-control",".carousel-control","[data-toggle=\"modal\"]","[data-toggle=\"dropdown\"]","[data-toggle=\"tooltip\"]","[data-toggle=\"popover\"]","[data-toggle=\"collapse\"]","[data-toggle=\"tab\"]","[data-toggle=\"pill\"]","[class*=upme]","[class*=um-]"],"deep":{"classes":[],"ids":[]}},"ReorderBlocks":"1","centerAllImg":"1","HasComments":"","LeftSidebarClass":".span3.left.tc-sidebar","RightSidebarClass":".span3.right.tc-sidebar","LoadModernizr":"1","stickyCustomOffset":{"_initial":0,"_scrolling":0,"options":{"_static":true,"_element":""}},"stickyHeader":"","dropdowntoViewport":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"dropcapEnabled":"0","dropcapWhere":{"post":"0","page":"0"},"dropcapMinWords":"50","dropcapSkipSelectors":{"tags":["IMG","IFRAME","H1","H2","H3","H4","H5","H6","BLOCKQUOTE","UL","OL"],"classes":["btn","tc-placeholder-wrap"],"id":[]},"imgSmartLoadEnabled":"0","imgSmartLoadOpts":{"parentSelectors":[".article-container",".__before_main_wrapper",".widget-front"],"opts":{"excludeImg":[".tc-holder-img"]}},"imgSmartLoadsForSliders":"","goldenRatio":"1.618","gridGoldenRatioLimit":"350","isSecondMenuEnabled":"","secondMenuRespSet":"in-sn-before","isParallaxOn":"1","parallaxRatio":"0.55","pluginCompats":[],"frontHelpNoticesOn":"","frontHelpNoticeParams":[],"adminAjaxUrl":"https:\/\/thishosting.rocks\/wp-admin\/admin-ajax.php","ajaxUrl":"https:\/\/thishosting.rocks\/?czrajax=1","frontNonce":{"id":"CZRFrontNonce","handle":"26a09cef0f"},"isDevMode":"","isModernStyle":"","i18n":{"Permanently dismiss":"Permanently dismiss"},"frontNotifications":{"styleSwitcher":{"enabled":false,"content":"","dismissAction":"dismiss_style_switcher_note_front","ajaxUrl":"https:\/\/thishosting.rocks\/wp-admin\/admin-ajax.php"}}};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/tc-scripts.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/footable/js/footable.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/coupon-popup/js/vex.js"></script><script type="text/javascript">
/* <![CDATA[ */
var settings = {"containerClass":"coupon-popup-container","linkClass":"coupon-popup-link","popupLinkClass":"coupon-popup-popup-link","popupClass":"coupon-popup-popup"};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/coupon-popup/js/coupon-popup.js"></script><link rel="https://api.w.org/" href="https://thishosting.rocks/wp-json/">
<link rel="alternate" type="application/json+oembed" href="https://thishosting.rocks/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F">
<link rel="alternate" type="text/xml+oembed" href="https://thishosting.rocks/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F&amp;format=xml">
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<script type="text/javascript">/* FooTable init code */

var $FOOTABLE = $FOOTABLE || {};
(function( $FOOTABLE, $, undefined ) {

	jQuery.fn.attrAppendWithComma=function(a,b){var c;return this.each(function(){c=$(this),void 0!==c.attr(a)&&""!=c.attr(a)?c.attr(a,c.attr(a)+","+b):c.attr(a,b)})};jQuery.fn.footableAttr=function(a,b){return this.each(function(){var c=$(this);c.data("auto-columns")!==!1&&(c.find("thead th:gt("+a+")").attrAppendWithComma("data-hide","tablet"),c.find("thead th:gt("+b+")").attrAppendWithComma("data-hide","phone"))})},jQuery.fn.footableFilter=function(a){return this.each(function(){var b=$(this);b.data("filter")||b.data("filter")===!1||b.data("filter-text-only","true").before('<div class="footable-filter-container"><input placeholder="'+a+'" style="float:right" type="text" class="footable-filter" />')})},jQuery.fn.footablePager=function(){return this.each(function(){var a=$(this);if(a.data("page")!==!1){var b=$('<tfoot class="hide-if-no-paging"><tr><td><div class="pagination pagination-centered">');b.find("td").attr("colspan",a.find("thead th").length),a.find("tbody:last").after(b)}})};

	$FOOTABLE.init = function() {
		$(".footable, .tablepress")
			.footableAttr(3,1)
			.footable( { breakpoints: { phone: 320, tablet: 768 } });

	};
}( $FOOTABLE, jQuery ));

jQuery(function($) {
	$FOOTABLE.init();
});
</script><meta name="onesignal" content="wordpress-plugin">
<link rel="manifest" href="https://thishosting.rocks/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script><script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://thishosting.rocks");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '85071c67-d519-4fec-b3e2-b0cfe224aa87';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://thishosting.rocks/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.19aac151-6a52-4f31-b603-0bf7908b06b4";
oneSignal_options['promptOptions'] = { };
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>
			  (adsbygoogle = window.adsbygoogle || []).push({
				google_ad_client: "ca-pub-6581914980257652",
				enable_page_level_ads: true
			  });
			</script><!-- Google Tag Manager --><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHHX4B3');</script><!-- End Google Tag Manager --><meta name="google-site-verification" content="tPeIBB1bPbcG5twYOojkUFxq4oVFgq1v3JWHyTinlOM">
<meta name="ahrefs-site-verification" content="04d05fe3bf0483fd2e56d080b4274e38438e0dc0df225cc0613d9d39ad4c4a09">
<link rel="icon" href="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-60x60.png" sizes="32x32">
<link rel="icon" href="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-300x300.png" sizes="192x192">
<link rel="apple-touch-icon-precomposed" href="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-300x300.png">
<meta name="msapplication-TileImage" content="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-300x300.png">
</head>
<body class="post-template-default single single-post postid-1896 single-format-standard tc-fade-hover-links tc-r-sidebar tc-center-images skin-blue tc-no-sticky-header sticky-disabled no-navbar tc-regular-menu tc-sticky-footer">

    
    <div id="tc-page-wrap" class="">

  		
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHHX4B3" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
 
	
  	   	<header class="tc-header clearfix row-fluid tc-tagline-off tc-title-logo-on  tc-shrink-on tc-menu-on logo-centered tc-second-menu-in-sn-before-when-mobile" role="banner"><div class="brand span3 pull-left">
        <a class="site-logo" href="https://thishosting.rocks/" title="ThisHosting.Rocks | Linux, Web Hosting, and Everything Else in Between"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2016/12/thr-logo.png" data-webp="https://thishosting.rocks/wp-content/uploads/2016/12/thr-logo.png.webp" data-alt="Back Home" data-height="100" data-width="884" data-class=" attachment-18" data-style="max-width:250px;max-height:100px" class="ewww_webp"><img src="https://thishosting.rocks/wp-content/uploads/2016/12/thr-logo.png" alt="Back Home" width="884" height="100" style="max-width:250px;max-height:100px" class=" attachment-18"></noscript></a>        </div> <!-- brand span3 -->

        <div class="container outside"><h2 class="site-description">Linux, Web Hosting, and Everything Else in Between</h2></div>      	<div class="navbar-wrapper clearfix span9 tc-submenu-fade tc-submenu-move tc-open-on-click pull-menu-center pull-menu-right">
        	<div class="navbar resp">
          		<div class="navbar-inner" role="navigation">
            		<div class="row-fluid">
              		<div class="social-block span5"><div class="social-links">
<a rel="nofollow" class="social-icon icon-feed" title="Subscribe to our RSS feed" aria-label="Subscribe to our RSS feed" href="https://thishosting.rocks/feed/" target="_blank" style="font-size:19px"><i class="fas fa-rss"></i></a><a rel="nofollow" class="social-icon icon-twitter" title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/thishostrocks" target="_blank" style="font-size:19px"><i class="fab fa-twitter"></i></a><a rel="nofollow" class="social-icon icon-facebook" title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/thishosting.rocks/" target="_blank" style="font-size:19px"><i class="fab fa-facebook"></i></a><a rel="nofollow" class="social-icon icon-google" title="Follow us on Google+" aria-label="Follow us on Google+" href="https://plus.google.com/107056993232136282396" target="_blank" style="font-size:19px"><i class="fab fa-google"></i></a>
</div></div>
<h2 class="span7 inside site-description">Linux, Web Hosting, and Everything Else in Between</h2>
<div class="nav-collapse collapse"><div class="menu-main-container"><ul id="menu-main-2" class="nav">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-17"><a href="https://thishosting.rocks/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://thishosting.rocks/category/coupons/">Coupons</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://thishosting.rocks/category/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://thishosting.rocks/category/directory/">Directory</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14"><a href="https://thishosting.rocks/category/knowledgebase/">Knowledgebase</a></li>
</ul></div></div>
<div class="btn-toggle-nav pull-right"><button type="button" class="btn menu-btn" data-toggle="collapse" data-target=".nav-collapse" title="Open the menu" aria-label="Open the menu"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span> </button></div>          			</div>
<!-- /.row-fluid -->
          		</div>
<!-- /.navbar-inner -->
        	</div>
<!-- /.navbar resp -->
      	</div>
<!-- /.navbar-wrapper -->
    	  		</header><div class="row-fluid tc-single-post-thumbnail-wrapper tc-singular-thumbnail-wrapper __before_main_wrapper"><section class="tc-thumbnail span12"><div class=""><a class="tc-rectangular-thumb" href="https://thishosting.rocks/comparing-elasticsearch-with-solr/" title="Comparing Elasticsearch with Solr"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-1170x500.jpg" data-webp="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-1170x500.jpg.webp" data-srcset-webp="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg.webp 1170w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-300x128.jpg.webp 300w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-768x328.jpg.webp 768w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-1024x438.jpg.webp 1024w" data-srcset-img="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg 1170w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-300x128.jpg 300w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-768x328.jpg 768w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-1024x438.jpg 1024w" data-alt="elasticsearch vs solr" data-height="500" data-width="1170" data-class="attachment-slider-full tc-thumb-type-thumb wp-post-image wp-post-image" data-sizes="(max-width: 1170px) 100vw, 1170px" class="ewww_webp"><img width="1170" height="500" src="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-1170x500.jpg" class="attachment-slider-full tc-thumb-type-thumb wp-post-image wp-post-image" alt="elasticsearch vs solr" srcset="https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr.jpg 1170w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-300x128.jpg 300w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-768x328.jpg 768w, https://thishosting.rocks/wp-content/uploads/2018/02/elasticsearch-vs-solr-1024x438.jpg 1024w" sizes="(max-width: 1170px) 100vw, 1170px"></noscript></a></div></section></div>
<div id="main-wrapper" class="container">

    <div class="tc-hot-crumble container" role="navigation"><div class="row"><div class="span12"><div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb">
<span class="trail-begin"><a href="https://thishosting.rocks" title="ThisHosting.Rocks" rel="home" class="trail-begin">ThisHosting.Rocks</a></span> <span class="sep">→</span> <a href="https://thishosting.rocks/category/knowledgebase/" title="Knowledgebase">Knowledgebase</a> <span class="sep">→</span> <span class="trail-end">Comparing Elasticsearch with Solr</span>
</div></div></div></div>
    <div class="container" role="main">
        <div class="row column-content-wrapper">

            
                <div id="content" class="span9 article-container tc-gallery-style">

                    
                        
                                                                                    
                                                                    <article id="post-1896" class="row-fluid post-1896 post type-post status-publish format-standard has-post-thumbnail hentry category-knowledgebase tag-elasticsearch tag-solr"><header class="entry-header"><h1 class="entry-title ">Comparing Elasticsearch with Solr   <span class="tc-update-notice label label-info">Recently updated!</span>
</h1>
<div class="entry-meta">This entry was posted in <a class="btn btn-mini btn-tag" href="https://thishosting.rocks/category/knowledgebase/" title="View all posts in Knowledgebase"> Knowledgebase </a> and tagged <a class="btn btn-mini" href="https://thishosting.rocks/tag/elasticsearch/" title="View all posts in elasticsearch"> elasticsearch </a><a class="btn btn-mini" href="https://thishosting.rocks/tag/solr/" title="View all posts in solr"> solr </a>   (updated on <a href="https://thishosting.rocks/2018/02/22/" title="8:29 pm" rel="bookmark"><time class="entry-date updated" datetime="2018-02-22T20:30:50+00:00">February 22, 2018</time></a>)</div>
<hr class="featurette-divider __before_content"></header><section class="entry-content "><div style="clear: both"></div>
<div style="float: right;position: relative;left: -50%;text-align: left;" class="the_champ_sharing_container the_champ_horizontal_sharing" super-socializer-data-href="https://thishosting.rocks/comparing-elasticsearch-with-solr/">
<div class="the_champ_sharing_title" style="font-weight: bold;list-style: none;position: relative;left: 50%;">Share this</div>
<ul style="list-style: none;position: relative;left: 50%;" class="the_champ_sharing_ul">
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Facebook" title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Twitter" title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=thishostrocks&amp;text=Comparing%20Elasticsearch%20with%20Solr&amp;url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Linkedin" title="Linkedin" class="theChampSharing theChampLinkedinBackground" onclick='theChampPopup("http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F&amp;title=Comparing%20Elasticsearch%20with%20Solr")'><ss style="display:block;" class="theChampSharingSvg theChampLinkedinSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Google plus" title="Google plus" class="theChampSharing theChampGoogleplusBackground" onclick='theChampPopup("https://plus.google.com/share?url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F")'><ss style="display:block;" class="theChampSharingSvg theChampGoogleplusSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://thishosting.rocks/comparing-elasticsearch-with-solr/', 'Comparing%20Elasticsearch%20with%20Solr', '')"><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li>
</ul>
<div style="clear:both"></div>
</div>
<div style="clear: both"></div>
<br><p><a href="http://lucene.apache.org/solr/">Solr</a> and <a href="https://www.elastic.co/products/elasticsearch">Elasticsearch</a> have emerged as the two leaders of open source search engines. While both have one thing in common, Lucene, they have plenty of differences. Because of this, one may be a better choice than the other. That depends largely on what your intended purposes are. Check out the following differences to determine which solution may be the best for your project.</p>
<p><span id="more-1896"></span></p>
<h2>Global vs. Segmented Caching</h2>
<p>It would take a significant amount of time to explain the details of each search engine’s use of caching. Instead, the important thing to note is that there is one significant difference between the methods each uses. In Lucene, indexes are comprised of data files. This information is in large part unchangeable. Indexes are divided up into segments. During the indexing process, new segments can be created. Further, Lucene can also create larger segments out of smaller ones.</p>
<p>The developers of Elasticsearch opted to use a one to one relationship between caches and segments. What this means is that if there is a change to a segment, only that small bit of data needs to be refreshed. On the other hand, Solr uses a global method. This means that when one thing changes within the cache, everything must be refreshed. This is a process that can take a significant amount of time, it’s also hardware intensive.</p>
<h2>Query Execution</h2>
<p>Everyone knows that range queries aren’t always the best for performance. This is due to the fact that a large chunk of data needs to be processed in order to determine whether or not the search criteria has been met. Doc values can reduce that processing time. In Elasticsearch, these values are automatically enabled. This means that the search engine knows if it needs to search all documents, or if it can focus on iterating through a subset. Currently, Solr does not appear to offer this. Because of this, range based queries may take longer.</p>
<h2>Node Discovery</h2>
<p>Each of these search engines takes a significantly different approach to node discovery. Node discovery is the process that is responsible for determining which action to take when one of the following occurs:</p>
<p>● The formation of a new cluster<br>
● When a node is damaged<br>
● When a node is added to a cluster</p>
<p>For this process, Solr has opted to use Apache Zookeeper. This is for both the processes of leader election and discovery. To accomplish this, it requires an external Zookeeper ensemble. To implement this, there is a need for a minimum of three Zookeeper instances. On the other hand, Elasticsearch has Zen. To achieve full tolerance, there must be three master nodes dedicated.</p>
<h2>High Performing and Precise Analysis Engines</h2>
<p>If your data is largely immutable, and high performance along with accuracy are a priority, Solr may be the better choice for you. In tests, Solr proved to outdo Elasticsearch in this area. There is little to no degradation in Solr thanks to the fact that there is no loss of precision.</p>
<h2>Development and Support</h2>
<p>Here, things are starkly different. To start, Elasticsearch is a fully commercial entity. Solr is a part of the Apache Software Foundation. Apache is a community-based, open source platform. Developers from all over contribute to the code, and anyone who proves their skills and commitment can become a committer. Here, it is the community that is in charge of the code base. Unsurprisingly, there is a significant amount of collaboration and community here. Anyone who has worked on Apache development projects before is familiar with the Apache philosophy and approach.</p>
<p>Then we have Elasticsearch. The code is open source and available for developers to use and modify, and it is possible to submit pull requests to have new code and modifications implemented. However, unlike Solr, the final arbiter of whether or not changes are made to the code base is up to the Elastic corporation. Community members are not allowed to be committers. That is limited to those who are employed by Elastic.</p>
<h2>Configuring and Installing The Products</h2>
<p>Currently, Elasticsearch has a distribution package size that is less than ⅙ the size of the one offered by Solr. The installation process is simpler for Elasticsearch as well. In fact, it can be installed and ready to run within minutes. It’s got an easy JSON configuration. However, because of its simplicity, there are limitations. For example, developers cannot leave comments for every configuration they change within the file.</p>
<p>Developers of Solr have done a good job of cleaning up some troublesome complications that existed in previous iterations. This has been accomplished largely with the use of Rest APIs. Complexities addressed include, documentation of clustering algorithms and custom sharded collections. Ultimately, your best choice will depend largely on your current project. If you are not using JSON, you may be better off bypassing Elasticsearch and going with SOLR.</p>
<h2>Index and Collection Leader Control</h2>
<p>Those who go with Elasticsearch will have to accept the fact that they have little control over deciding whether or not particular shards will become primaries or become replicas. This is in spite of the fact that Elasticsearch is highly dynamic in the area of placing shards around the cluster. Conversely, Solr does allow users much more control. Thanks to this, developers have the ability to rebalance leaders. This results in the ability to create a balanced load across each cluster.</p>
<p><a href="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg" class="grouped_elements" rel="tc-fancybox-group1896"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg" data-webp="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg.webp" data-srcset-webp="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg.webp 850w, https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch-300x141.jpg.webp 300w, https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch-768x361.jpg.webp 768w" data-srcset-img="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg 850w, https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch-300x141.jpg 300w, https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch-768x361.jpg 768w" data-alt="machine learning - solr vs elasticsearch" data-height="400" data-width="850" data-class="alignnone size-full wp-image-1900" data-sizes="(max-width: 850px) 100vw, 850px" class="ewww_webp"><img class="alignnone size-full wp-image-1900" src="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg" alt="machine learning - solr vs elasticsearch" width="850" height="400" srcset="https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch.jpg 850w, https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch-300x141.jpg 300w, https://thishosting.rocks/wp-content/uploads/2018/02/machine-learning-solr-vs-elasticsearch-768x361.jpg 768w" sizes="(max-width: 850px) 100vw, 850px"></noscript></a></p>
<h2>Machine Learning Capabilities</h2>
<p>For machine learning, Elasticsearch has gone with X-Pack. This is a commercial plugin that works with Kibana. It provides support for machine learning algorithms. These are largely focused on detecting outliers and anomalies that may be found in time series data. The good news is that there are some very nice tools along with professional services. The bad news is that one has to open their wallet and shell out quite a bit of cash. Elasticsearch users might consider alternatives. There are solutions available via cloud services, commercial software houses, and open source tools.</p>
<p>Solr provides machine learning support for free. This comes by way of a contrib module as well as a streaming aggregations framework. By making use of other libraries developers can use machine learning-based feature extraction and ranking models. Here, machine learning is largely focused on classification that works by implementing logistic regression.</p>
<h2>Tools and Features</h2>
<p>Here, Elasticsearch takes the lead. There’s a long list of tools that can be used with Elasticsearch. There’s Kibana, for example. If you are interested in running SQL you can do that with the combination of Solr and Apache Zeppelin. There are other tools as well. However, we feel as if not much has been done here that’s really groundbreaking or innovative.</p>
<p>Conversely, the Elasticsearch ecosystem is more up to date, and we believe there is much more to speak of here. It works with a new version of Kibana that is constantly being updated with new features. If that isn’t your preference, definitely check out Grafana. It holds its own and offers multiple features. These aren’t the only two tools that work cooperatively with Elasticsearch either. Several tools have been created that make use of Elasticsearch as a data source. This includes multiple data shippers. It’s also important to mention that use of Elasticsearch isn’t just popular among open source enthusiasts. There are several businesses who have gotten on board here.</p>
<h2>DevOps Experience</h2>
<p>One undeniably important consideration is how DevOps folks feel about these two products. Here, Solr falls a bit behind, but there are still positives and hope for the future. Information that DevOps people need is often fragmented and incomplete. Some information can be gleaned through JMX MBean. There’s also a new Solr Metrics API. There’s a lot of work to be done here, but progress is being made.</p>
<p>Elasticsearch has come quite a bit further at this stage. Troubleshooting Elasticsearch is an easier process as developers are able to easily get information such as work statistics, disk usage, memory, usage of thread pools, caching and buffer information, and more. This is on top of the higher functioning API, easy installation process, and overall manageability.</p>
<h2>Speed</h2>
<p>It isn’t possible to label one of these search engines as being faster than the other. Speed of performance largely depends on the situation. We discovered that Elasticsearch works very well in environments where data is fluid and changes rapidly. On the other hand, thanks to the way it uses caching, and the use of an uninverted reader for the process of sorting and faceting, Solr is a top performer when data is largely static.</p>
<h2>Full Text Search Capabilities</h2>
<p>Here, Solr is full of features relating to full-text search. Not only that, but these features are impressively rich. Just check out the Solr code base to learn more. These include the ability to correct spelling mistakes, a variety of request parsers, configurable highlighting support, and suggester implementations.</p>
<p>With Elasticsearch there is a single, dedicated suggesters API. In this case, the details of the implementation are not available to users or developers. This means it is simple to implement. However, there is no opportunity to customize or configure the implementation. This results in lower flexibility. Both products’ highlighting is based on Lucene. However, Solr offers many more options here when it comes to configuration.</p>
<h2>Try Them Out</h2>
<p>You can best learn about both Solr and Elasticsearch by actually trying them out and comparing them first-hand. You can spin up a cloud server at <a class="thirstylink" title="Vultr" href="https://thishosting.rocks/go/vultr/" target="_blank" rel="nofollow noopener">Vultr</a> (with hourly billing, so you don’t have to pay for a full month), and try both of them. You can also use any other <a href="https://thishosting.rocks/cheap-cloud-hosting-providers-comparison/">cloud hosting provider</a> with root access.</p>
<h2>Solr vs Elasticsearch – Conclusion</h2>
<p>It is really impossible to declare either one of these products a winner or a loser. Each has areas in which they clearly come out ahead and areas where they fall behind. Then there are areas where each product is pretty much neck and neck. Ultimately, the best choice for developers depends on several factors. What kind of development community and environment do you prefer? How important is ease of installation and configuration? Most importantly, what kind of data will the search engine need to process? Hopefully, the comparisons made above will make this decision easier to make.</p>
<h2>About the Author</h2>
<p><em>This article was submitted to us by a third-party writer. The views and opinions expressed in this article are those of the author and do not reflect the views and opinions of ThisHosting.Rocks. If you want to write for ThisHosting.Rocks, go <a href="https://thishosting.rocks/write-for-us/">here</a>.</em></p>
<h3>Amanda Sparks</h3>
<p><a href="https://thishosting.rocks/wp-content/uploads/2018/02/amanda2sparks.jpg" class="grouped_elements" rel="tc-fancybox-group1896"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2018/02/amanda2sparks.jpg" data-webp="https://thishosting.rocks/wp-content/uploads/2018/02/amanda2sparks.jpg.webp" data-alt="amanda2sparks" data-height="100" data-width="100" data-class="size-full wp-image-1902 alignleft" class="ewww_webp"><img class="size-full wp-image-1902 alignleft" src="https://thishosting.rocks/wp-content/uploads/2018/02/amanda2sparks.jpg" alt="amanda2sparks" width="100" height="100"></noscript></a>Pro writer, amateur human and head of content at <a href="https://www.essaysupply.com/">Essay Supply</a>, former lifestyle writer at Huffington Post. “<em>I am an analogue soul that is stuck in the digital world… And I seem to like it!</em>”<br><a href="https://twitter.com/amanda2sparks">Follow Amanda on Twitter</a></p>

<div id="jp-relatedposts" class="jp-relatedposts">
	<h3 class="jp-relatedposts-headline"><em>Related Content</em></h3>
</div>
<br><div style="clear: both"></div>
<div style="float: right;position: relative;left: -50%;text-align: left;" class="the_champ_sharing_container the_champ_horizontal_sharing" super-socializer-data-href="https://thishosting.rocks/comparing-elasticsearch-with-solr/">
<div class="the_champ_sharing_title" style="font-weight: bold;list-style: none;position: relative;left: 50%;">Share this</div>
<ul style="list-style: none;position: relative;left: 50%;" class="the_champ_sharing_ul">
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Facebook" title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Twitter" title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=thishostrocks&amp;text=Comparing%20Elasticsearch%20with%20Solr&amp;url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Linkedin" title="Linkedin" class="theChampSharing theChampLinkedinBackground" onclick='theChampPopup("http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F&amp;title=Comparing%20Elasticsearch%20with%20Solr")'><ss style="display:block;" class="theChampSharingSvg theChampLinkedinSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Google plus" title="Google plus" class="theChampSharing theChampGoogleplusBackground" onclick='theChampPopup("https://plus.google.com/share?url=https%3A%2F%2Fthishosting.rocks%2Fcomparing-elasticsearch-with-solr%2F")'><ss style="display:block;" class="theChampSharingSvg theChampGoogleplusSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://thishosting.rocks/comparing-elasticsearch-with-solr/', 'Comparing%20Elasticsearch%20with%20Solr', '')"><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li>
</ul>
<div style="clear:both"></div>
</div>
<div style="clear: both"></div>                                      </section><!-- .entry-content --></article><div id="comments" class="comments-area">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/comparing-elasticsearch-with-solr/#respond" style="display:none;">Cancel reply</a></small>
</h3>			<form action="https://thishosting.rocks/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p>
<p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required="true" required="required"></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required="true" required="required"></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200"></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"><input type="hidden" name="comment_post_ID" value="1896" id="comment_post_ID"><input type="hidden" name="comment_parent" id="comment_parent" value="0"></p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4e9b5ac6be"></p>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="240"></p>			</form>
			</div>
<!-- #respond -->
	</div>
<!-- //#comments .comments-area -->

        
          <hr class="featurette-divider __after_loop">
<nav id="nav-below" class="navigation" role="navigation"><h3 class="assistive-text">
                Post navigation              </h3>

              <ul class="pager">
<li class="previous">
                    <span class="nav-previous">
                      <a href="https://thishosting.rocks/how-to-make-a-minecraft-server/" rel="prev"><span class="meta-nav">←</span> How to Make a Minecraft Server</a>                    </span>
                  </li>
                                              </ul></nav><!-- //#nav-below .navigation -->
</div>
<!--.article-container -->

           
        <div class="span3 right tc-sidebar no-widget-icons">
           <div id="right" class="widget-area" role="complementary">
              <aside id="search-3" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://thishosting.rocks/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s"><input type="submit" id="searchsubmit" value="Search">
</div>
			</form></aside><aside id="text-5" class="widget widget_text"><h3 class="widget-title">Follow us:</h3>			<div class="textwidget">
<a href="https://www.facebook.com/thishosting.rocks/"><i class="fab fa-facebook fa-3x" style="padding-right:10px;"></i></a>
<a href="https://twitter.com/thishostrocks"><i class="fab fa-twitter fa-3x" style="padding-right:10px;"></i></a>    
<a href="https://plus.google.com/+ThisHostingRocks"><i class="fab fa-google fa-3x" style="padding-right:10px;"></i></a>
<a href="https://thishosting.rocks/feed/rss/"><i class="fas fa-rss fa-3x" style="padding-right:10px;"></i></a>
<a href="https://www.patreon.com/thishostingrocks"><i class="fab fa-patreon fa-3x"></i></a>
</div>
		</aside><aside id="text-10" class="widget widget_text"><div class="textwidget">
<p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br><!-- THR Responsive Sidebar 2 --><br><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6581914980257652" data-ad-slot="8021595724" data-ad-format="auto"></ins><br><script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</aside><aside id="text-14" class="widget widget_text"><div class="textwidget">
<div class="alert alert-info text-center">
<h3><strong>Great Web Hosting With Even Greater Support<br></strong></h3>
<p>Get web hosting with great 24/7 support and ultra-fast servers!<br><a class="btn btn-large btn-success" role="button" href="https://thishosting.rocks/go/a2-hosting/" target="_blank" rel="nofollow noopener">GET HOSTED</a></p>
<p class="small"><em>A coupon is automatically applied to your order</em></p>
</div>
<div class="alert alert-info text-center">
<h3><strong>Fast, Scalable, SSD Cloud Hosting<br></strong></h3>
<p>Get the best, most reliable, fastest, cheapest Cloud Server Hosting from <a href="https://thishosting.rocks/go/vultr/" target="_blank" rel="nofollow noopener">Vultr</a><br><a class="btn btn-large btn-success" role="button" href="https://thishosting.rocks/go/vultr/" target="_blank" rel="nofollow noopener">Go to Vultr</a></p>
<p class="small"><em><a href="https://thishosting.rocks/vultr-coupons-for-2017-free-credits-and-more/" target="_blank" rel="noopener">Get Free Vultr Credits</a></em></p>
</div>
</div>
		</aside>
</div>
<!-- //#left or //#right -->
        </div>
<!--.tc-sidebar -->

        
        </div>
<!--.row -->
    </div>
<!-- .container role: main -->

    <div id="tc-push-footer"></div>
</div>
<!-- //#main-wrapper -->

  		<!-- FOOTER -->
  		<footer id="footer" class=""><div class="container footer-widgets  no-widget-icons">
                    <div class="row widget-area" role="complementary">
												
							<div id="footer_one" class="span4">
																
										<aside id="text-2" class="widget widget_text"><h3 class="widget-title">ThisHosting.Rocks</h3>			<div class="textwidget">
<a href="https://thishosting.rocks/about/"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2016/12/thr-inverted.png" data-webp="https://thishosting.rocks/wp-content/uploads/2016/12/thr-inverted.png.webp" data-alt="thishosting.rocks inverted logo" data-style="display: block; margin: 0 auto;" class="ewww_webp"><img style="display: block; margin: 0 auto;" src="https://thishosting.rocks/wp-content/uploads/2016/12/thr-inverted.png" alt="thishosting.rocks inverted logo"></noscript></a> <br>
We are <strong>T</strong>his<strong>H</strong>osting.<strong>R</strong>ocks. We love hosting providers that rock! We write original content on Web Hosting, Linux, and everything else in between. Our goal is to cover as much as we can and help everyone learn more through our free resources. <br>
2016-2018 © ThisHosting.Rocks</div>
		</aside>
</div>
<!-- .{$key}_widget_class -->

						
							<div id="footer_two" class="span4">
																
										<aside id="text-3" class="widget widget_text"><h3 class="widget-title">THR Support</h3>			<div class="textwidget"><div class="alert alert-success text-center">
<h3 style="color:#005580;"><strong>Need Hosting/Server Support?</strong></h3> <p style="text-align:center;color:#005580;">We are perfect for you, if you want to outsource the support of your web hosting company or if you need server management services. Contact us and get our Expert THR Support Team. </p> <a class="btn btn-large btn-success" href="https://thishosting.rocks/support/" role="button">Get Support</a>
</div></div>
		</aside>
</div>
<!-- .{$key}_widget_class -->

						
							<div id="footer_three" class="span4">
																
										<aside id="nav_menu-3" class="widget widget_nav_menu"><h3 class="widget-title">THR Stuff</h3>
<div class="menu-footer-container"><ul id="menu-footer" class="menu">
<li id="menu-item-1647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1647"><a href="https://thishosting.rocks/thank-you/">Thank You!</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56"><a href="https://thishosting.rocks/about/">About</a></li>
<li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57"><a href="https://thishosting.rocks/affiliate-disclosure/">Affiliate Disclosure</a></li>
<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59"><a href="https://thishosting.rocks/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-1505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1505"><a href="https://thishosting.rocks/category/insider/">Insider</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60"><a href="https://thishosting.rocks/tos/">Terms and Conditions</a></li>
<li id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97"><a href="https://thishosting.rocks/submit-coupon/">Submit Coupon</a></li>
<li id="menu-item-998" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-998"><a href="https://thishosting.rocks/write-for-us/">Write for Us</a></li>
<li id="menu-item-239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-239"><a href="https://thishosting.rocks/support">Support</a></li>
<li id="menu-item-58" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58"><a href="https://thishosting.rocks/contact/">Contact us</a></li>
</ul></div></aside><aside id="text-4" class="widget widget_text"><div class="textwidget">
<a href="https://www.facebook.com/thishosting.rocks/"><i class="fab fa-facebook fa-3x" style="padding-right:10px;"></i></a>
<a href="https://twitter.com/thishostrocks"><i class="fab fa-twitter fa-3x" style="padding-right:10px;"></i></a>    
<a href="https://plus.google.com/+ThisHostingRocks"><i class="fab fa-google fa-3x" style="padding-right:10px;"></i></a>
<a href="https://thishosting.rocks/feed/rss/"><i class="fas fa-rss fa-3x" style="padding-right:10px;"></i></a>
<a href="https://www.patreon.com/thishostingrocks"><i class="fab fa-patreon fa-3x"></i></a>
</div>
		</aside>
</div>
<!-- .{$key}_widget_class -->

																	</div>
<!-- .row.widget-area -->
				</div>
<!--.footer-widgets -->
				    	   		</footer>
</div>
<!-- //#tc-page-wrapper -->
		<link rel="stylesheet" id="coupon-popup-css" href="https://thishosting.rocks/wp-content/plugins/coupon-popup/css/coupon-popup.css" type="text/css" media="all">
<link rel="stylesheet" id="vex-css" href="https://thishosting.rocks/wp-content/plugins/coupon-popup/css/vex.css" type="text/css" media="all">
<script type="text/javascript">
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/thishosting.rocks\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/contact-form-7/includes/js/scripts.js"></script><script type="text/javascript" src="https://s0.wp.com/wp-content/js/devicepx-jetpack.js"></script><script type="text/javascript">
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/thishosting.rocks","ajax_url":"https:\/\/thishosting.rocks\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"go","link_prefixes":{"1":"link","2":"review","3":"recommends","9":"","10":"go"},"post_id":"1896","disable_thirstylink_class":""};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/thirstyaffiliates/js/app/ta.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/comment-reply.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/ui/core.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/assets/front/js/libs/modernizr.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/ui/effect.min.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/assets/front/js/libs/retina.min.js"></script><script type="text/javascript">
/* <![CDATA[ */
var q2w3_sidebar_options = [{"sidebar":"cs-2","margin_top":30,"margin_bottom":0,"stop_id":"footer","screen_max_width":0,"screen_max_height":0,"width_inherit":true,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["text-24"]},{"sidebar":"right","margin_top":30,"margin_bottom":0,"stop_id":"footer","screen_max_width":0,"screen_max_height":0,"width_inherit":true,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["text-14"]}];
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js"></script><script type="text/javascript">
/* <![CDATA[ */
var the_champ_sl_ajax_token = {"ajax_url":"https:\/\/thishosting.rocks\/wp-admin\/admin-ajax.php","security":"a8b39e194d"};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/super-socializer/js/front/combined.js"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/wp-embed.min.js"></script><script async="async" type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/akismet/_inc/form.js"></script>
</body>
</html>