<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7 no-js" lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8 no-js" lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html class="no-js" lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<!--<![endif]-->
					<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://thishosting.rocks/xmlrpc.php">
<!-- html5shiv for IE8 and less  --><!--[if lt IE 9]>
				      <script src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/html5.js"></script>
				    <![endif]--><script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script><title>How to Install Docker on Ubuntu 16.04 | ThisHosting.Rocks</title>
<script>function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script><script type="text/javascript">var theChampCloseIconPath = 'https://thishosting.rocks/wp-content/plugins/super-socializer/images/close.png';</script><script> var theChampSiteUrl = 'https://thishosting.rocks', theChampVerified = 0, theChampEmailPopup = 0; </script><script> var theChampFBKey = '', theChampFBLang = 'en_US', theChampFbLikeMycred = 0, theChampSsga = 0, theChampCommentNotification = 0, theChampHeateorFcmRecentComments = 0, theChampFbIosLogin = 0; </script><script> var theChampSharingAjaxUrl = 'https://thishosting.rocks/wp-admin/admin-ajax.php', heateorSsUrlCountFetched = [], heateorSsSharesText = 'Shares', heateorSsShareText = 'Share', theChampPluginIconPath = 'https://thishosting.rocks/wp-content/plugins/super-socializer/images/logo.png', theChampHorizontalSharingCountEnable = 0, theChampVerticalSharingCountEnable = 0, theChampSharingOffset = -10, theChampCounterOffset = -10;
				</script><style type="text/css">
	.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}@media screen and (max-width:783px){.the_champ_bottom_sharing{left:0px!important;right:auto!important;display:block!important;width: auto!important;bottom: -10px!important;top: auto!important;}.the_champ_bottom_sharing .the_champ_square_count{line-height: inherit;}.the_champ_bottom_sharing .theChampSharingArrow{display:none;}.the_champ_bottom_sharing .theChampTCBackground{margin-right: 1.1em !important}}	</style>
<!-- All in One SEO Pack 2.3.12.5 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] --><link rel="author" href="https://plus.google.com/107056993232136282396">
<meta name="description" content="We'll show you how to install Docker on your Ubuntu 16.04 server. Short and straight-to-the-point tutorial. With Docker, you can build, ship and run">
<meta name="keywords" content="docker,ubuntu,knowledgebase">
<link rel="canonical" href="https://thishosting.rocks/install-docker-on-ubuntu/">
<meta property="og:title" content="How to Install Docker on Ubuntu 16.04 | ThisHosting.Rocks">
<meta property="og:type" content="article">
<meta property="og:url" content="https://thishosting.rocks/install-docker-on-ubuntu/">
<meta property="og:image" content="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1024x445.jpg">
<meta property="og:site_name" content="ThisHosting.Rocks">
<meta property="fb:admins" content="1432524117">
<meta property="fb:app_id" content="592468017630007">
<meta property="og:description" content="We'll show you how to install Docker on your Ubuntu 16.04 server. Short and straight-to-the-point tutorial. With Docker, you can build, ship and run applications inside your server in containers. Essentially, with Docker, you get &quot;virtual machines&quot; inside your virtual machine.  Docker requirements You can't run Docker on just about any server. Here are the requirements:  64-bit server. At least 512MB RAM. Linux Kernel 3.10+. Latest version recommended. An Ubuntu 16.04 VPS (for the purposes of this tutorial). You can get one from Vultr, starting from $2.5 a month. Note that you can't run Docker on an OpenVZ VPS.  Update your server Always update your server before doing anything. Run the following command: sudo apt-get update &amp;&amp; apt-get upgrade -y Install the latest version of Docker If you use Ubuntu's default repositories, you may not get the latest version of Docker, so to get the latest one, follow the steps below. Add the key for the official Docker repository to your">
<meta property="article:tag" content="docker">
<meta property="article:tag" content="ubuntu">
<meta property="article:tag" content="knowledgebase">
<meta property="article:publisher" content="https://www.facebook.com/thishosting.rocks/">
<meta property="article:published_time" content="2017-05-07T16:04:32Z">
<meta property="article:modified_time" content="2017-05-07T16:04:32Z">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@thishostrocks">
<meta name="twitter:domain" content="thishosting.rocks">
<meta name="twitter:title" content="How to Install Docker on Ubuntu 16.04 | ThisHosting.Rocks">
<meta name="twitter:description" content="We'll show you how to install Docker on your Ubuntu 16.04 server. Short and straight-to-the-point tutorial. With Docker, you can build, ship and run applications inside your server in containers. Essentially, with Docker, you get &quot;virtual machines&quot; inside your virtual machine.  Docker requirements You can't run Docker on just about any server. Here are the requirements:  64-bit server. At least 512MB RAM. Linux Kernel 3.10+. Latest version recommended. An Ubuntu 16.04 VPS (for the purposes of this tutorial). You can get one from Vultr, starting from $2.5 a month. Note that you can't run Docker on an OpenVZ VPS.  Update your server Always update your server before doing anything. Run the following command: sudo apt-get update &amp;&amp; apt-get upgrade -y Install the latest version of Docker If you use Ubuntu's default repositories, you may not get the latest version of Docker, so to get the latest one, follow the steps below. Add the key for the official Docker repository to your">
<meta name="twitter:image" content="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1024x445.jpg">
<meta itemprop="image" content="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1024x445.jpg">
<!-- /all in one seo pack --><link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="alternate" type="application/rss+xml" title="ThisHosting.Rocks » Feed" href="https://thishosting.rocks/feed/">
<link rel="alternate" type="application/rss+xml" title="ThisHosting.Rocks » Comments Feed" href="https://thishosting.rocks/comments/feed/">
<link rel="alternate" type="application/rss+xml" title="ThisHosting.Rocks » How to Install Docker on Ubuntu 16.04 Comments Feed" href="https://thishosting.rocks/install-docker-on-ubuntu/feed/">
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thishosting.rocks\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style type="text/css">
	.tablepress thead th div { float:left; }
</style>
<link rel="stylesheet" id="tc-gfonts-css" href="//fonts.googleapis.com/css?family=Raleway%7CRaleway" type="text/css" media="all">
<link rel="stylesheet" id="contact-form-7-css" href="https://thishosting.rocks/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7" type="text/css" media="all">
<link rel="stylesheet" id="customizr-fa-css" href="https://thishosting.rocks/wp-content/themes/customizr/assets/shared/fonts/fa/css/font-awesome.min.css?ver=3.5.12" type="text/css" media="all">
<link rel="stylesheet" id="customizr-common-css" href="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/css/tc_common.min.css?ver=3.5.12" type="text/css" media="all">
<link rel="stylesheet" id="customizr-skin-css" href="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/css/blue.min.css?ver=3.5.12" type="text/css" media="all">
<style id="customizr-skin-inline-css" type="text/css">

                  .site-title,.site-description,h1,h2,h3,.tc-dropcap {
                    font-family : 'Raleway';
                    font-weight : inherit;
                  }

                  body,.navbar .nav>li>a {
                    font-family : 'Raleway';
                    font-weight : inherit;
                  }

            body,.navbar .nav>li>a {
              font-size : 16px;
              line-height : 1.6em;
            }
table { border-collapse: separate; }
                           body table { border-collapse: collapse; }
                          
.social-links .social-icon:before { content: none } 
header.tc-header {border-top: none;}

.sticky-enabled .tc-shrink-on .site-logo img {
    					height:30px!important;width:auto!important
    				}

    				.sticky-enabled .tc-shrink-on .brand .site-title {
    					font-size:0.6em;opacity:0.8;line-height:1.2em
    				}

.tc-single-post-thumbnail-wrapper .tc-rectangular-thumb {
          max-height: 300px;
          height :300px
        }

        .tc-center-images .tc-single-post-thumbnail-wrapper .tc-rectangular-thumb img {
          opacity : 0;
          -webkit-transition: opacity .5s ease-in-out;
          -moz-transition: opacity .5s ease-in-out;
          -ms-transition: opacity .5s ease-in-out;
          -o-transition: opacity .5s ease-in-out;
          transition: opacity .5s ease-in-out;
        }

.tc-slider-loader-wrapper{ display:none }
html.js .tc-slider-loader-wrapper { display: block }.no-csstransforms3d .tc-slider-loader-wrapper .tc-img-gif-loader {
                                                background: url('https://thishosting.rocks/wp-content/themes/customizr/assets/front/img/slider-loader.gif') no-repeat center center;
                                         }.tc-slider-loader-wrapper .tc-css-loader > div { border-color:#08c; }
</style>
<link rel="stylesheet" id="customizr-style-css" href="https://thishosting.rocks/wp-content/themes/thishostingrocks/style.css?ver=3.5.12" type="text/css" media="all">
<link rel="stylesheet" id="fancyboxcss-css" href="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/fancybox/jquery.fancybox-1.3.4.min.css?ver=4.7.4" type="text/css" media="all">
<link rel="stylesheet" id="the_champ_frontend_css-css" href="https://thishosting.rocks/wp-content/plugins/super-socializer/css/front.css?ver=7.8.20" type="text/css" media="all">
<link rel="stylesheet" id="the_champ_sharing_default_svg-css" href="https://thishosting.rocks/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.8.20" type="text/css" media="all">
<link rel="stylesheet" id="tablepress-default-css" href="https://thishosting.rocks/wp-content/plugins/tablepress/css/default.min.css?ver=1.8" type="text/css" media="all">
<link rel="stylesheet" id="footable-core-min-css" href="https://thishosting.rocks/wp-content/plugins/footable/css/footable.core.min.css?ver=0.3.1" type="text/css" media="all">
<link rel="stylesheet" id="footable-metro-min-css" href="https://thishosting.rocks/wp-content/plugins/footable/css/footable.metro.min.css?ver=0.3.1" type="text/css" media="all">
<script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/jquery.js?ver=1.12.4"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/fancybox/jquery.fancybox-1.3.4.min.js?ver=3.5.12"></script><script type="text/javascript">
/* <![CDATA[ */
var TCParams = {"_disabled":[],"FancyBoxState":"1","FancyBoxAutoscale":"1","SliderName":"","SliderDelay":"","SliderHover":"1","centerSliderImg":"1","SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"anchorSmoothScroll":"easeOutExpo","anchorSmoothScrollExclude":{"simple":["[class*=edd]",".tc-carousel-control",".carousel-control","[data-toggle=\"modal\"]","[data-toggle=\"dropdown\"]","[data-toggle=\"tooltip\"]","[data-toggle=\"popover\"]","[data-toggle=\"collapse\"]","[data-toggle=\"tab\"]","[class*=upme]","[class*=um-]"],"deep":{"classes":[],"ids":[]}},"ReorderBlocks":"1","centerAllImg":"1","HasComments":"","LeftSidebarClass":".span3.left.tc-sidebar","RightSidebarClass":".span3.right.tc-sidebar","LoadModernizr":"1","stickyCustomOffset":{"_initial":0,"_scrolling":0,"options":{"_static":true,"_element":""}},"stickyHeader":"","dropdowntoViewport":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"dropcapEnabled":"0","dropcapWhere":{"post":"0","page":"0"},"dropcapMinWords":"50","dropcapSkipSelectors":{"tags":["IMG","IFRAME","H1","H2","H3","H4","H5","H6","BLOCKQUOTE","UL","OL"],"classes":["btn"],"id":[]},"imgSmartLoadEnabled":"0","imgSmartLoadOpts":{"parentSelectors":[".article-container",".__before_main_wrapper",".widget-front"],"opts":{"excludeImg":[".tc-holder-img"]}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","isSecondMenuEnabled":"","secondMenuRespSet":"in-sn-before","isParallaxOn":"1","parallaxRatio":"0.55","pluginCompats":[],"frontHelpNoticesOn":"","frontHelpNoticeParams":[],"ajaxUrl":"https:\/\/thishosting.rocks\/wp-admin\/admin-ajax.php","isDevMode":""};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/tc-scripts.min.js?ver=3.5.12"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/footable/js/footable.min.js?ver=0.3.1"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/coupon-popup/js/vex.js?ver=4.7.4"></script><script type="text/javascript">
/* <![CDATA[ */
var settings = {"containerClass":"coupon-popup-container","linkClass":"coupon-popup-link","popupLinkClass":"coupon-popup-popup-link","popupClass":"coupon-popup-popup"};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/coupon-popup/js/coupon-popup.js?ver=4.7.4"></script><link rel="https://api.w.org/" href="https://thishosting.rocks/wp-json/">
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thishosting.rocks/xmlrpc.php?rsd">
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thishosting.rocks/wp-includes/wlwmanifest.xml">
<link rel="prev" title="Valid coupons for Cloudways [2017]" href="https://thishosting.rocks/valid-coupons-for-cloudways-2017/">
<meta name="generator" content="WordPress 4.7.4">
<link rel="shortlink" href="https://thishosting.rocks/?p=615">
<link rel="alternate" type="application/json+oembed" href="https://thishosting.rocks/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthishosting.rocks%2Finstall-docker-on-ubuntu%2F">
<link rel="alternate" type="text/xml+oembed" href="https://thishosting.rocks/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthishosting.rocks%2Finstall-docker-on-ubuntu%2F&amp;format=xml">
<script>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</script><script type="text/javascript">
                    var cwpCustomBarIcon = '';
                    var isSetToPro = '';
                    var trackcolor = '#ebebeb';
                </script><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<script type="text/javascript">/* FooTable init code */

var $FOOTABLE = $FOOTABLE || {};
(function( $FOOTABLE, $, undefined ) {

	jQuery.fn.attrAppendWithComma=function(a,b){var c;return this.each(function(){c=$(this),void 0!==c.attr(a)&&""!=c.attr(a)?c.attr(a,c.attr(a)+","+b):c.attr(a,b)})};jQuery.fn.footableAttr=function(a,b){return this.each(function(){var c=$(this);c.data("auto-columns")!==!1&&(c.find("thead th:gt("+a+")").attrAppendWithComma("data-hide","tablet"),c.find("thead th:gt("+b+")").attrAppendWithComma("data-hide","phone"))})},jQuery.fn.footableFilter=function(a){return this.each(function(){var b=$(this);b.data("filter")||b.data("filter")===!1||b.data("filter-text-only","true").before('<div class="footable-filter-container"><input placeholder="'+a+'" style="float:right" type="text" class="footable-filter" />')})},jQuery.fn.footablePager=function(){return this.each(function(){var a=$(this);if(a.data("page")!==!1){var b=$('<tfoot class="hide-if-no-paging"><tr><td><div class="pagination pagination-centered">');b.find("td").attr("colspan",a.find("thead th").length),a.find("tbody:last").after(b)}})};

	$FOOTABLE.init = function() {
		$(".footable, .tablepress")
			.footableAttr(3,1)
			.footable( { breakpoints: { phone: 320, tablet: 768 } });

	};
}( $FOOTABLE, jQuery ));

jQuery(function($) {
	$FOOTABLE.init();
});
</script><link rel="amphtml" href="https://thishosting.rocks/install-docker-on-ubuntu/amp/">
<meta property="article:author" content="https://www.facebook.com/thishosting.rocks/">
<!-- Google Tag Manager --><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHHX4B3');</script><!-- End Google Tag Manager --><meta name="google-site-verification" content="tPeIBB1bPbcG5twYOojkUFxq4oVFgq1v3JWHyTinlOM">
<link rel="icon" href="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-32x32.png" sizes="32x32">
<link rel="icon" href="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-192x192.png" sizes="192x192">
<link rel="apple-touch-icon-precomposed" href="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-180x180.png">
<meta name="msapplication-TileImage" content="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-t-270x270.png">
</head>
<body class="post-template-default single single-post postid-615 single-format-standard tc-fade-hover-links tc-r-sidebar tc-center-images skin-blue tc-no-sticky-header sticky-disabled no-navbar tc-regular-menu" itemscope itemtype="http://schema.org/WebPage">

    
    <div id="tc-page-wrap" class="">

  		
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHHX4B3" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
 
	
  	   	<header class="tc-header clearfix row-fluid tc-tagline-off tc-title-logo-on  tc-shrink-on tc-menu-on logo-left tc-second-menu-in-sn-before-when-mobile" role="banner"><div class="brand span3 pull-left">
        <a class="site-logo" href="https://thishosting.rocks/" title="ThisHosting.Rocks | The Best Web Hosting Resources"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-cropped-thr-logo.png" data-webp="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-cropped-thr-logo.png.webp" data-alt="Back Home" data-height="100" data-width="884" data-class=" attachment-333" data-style="max-width:250px;max-height:100px" class="ewww_webp"><img src="https://thishosting.rocks/wp-content/uploads/2016/12/cropped-cropped-thr-logo.png" alt="Back Home" width="884" height="100" style="max-width:250px;max-height:100px" class=" attachment-333"></noscript></a>        </div> <!-- brand span3 -->

        <div class="container outside"><h2 class="site-description">The Best Web Hosting Resources</h2></div>      	<div class="navbar-wrapper clearfix span9 tc-submenu-fade tc-submenu-move tc-open-on-click pull-menu-right">
        	<div class="navbar resp">
          		<div class="navbar-inner" role="navigation">
            		<div class="row-fluid">
              		<div class="social-block span5"><div class="social-links">
<a rel="nofollow" class="social-icon icon-feed" title="Subscribe to our rss feed" aria-label="Subscribe to our rss feed" href="https://thishosting.rocks/feed/" target="_blank"><i class="fa fa-rss"></i></a><a rel="nofollow" class="social-icon icon-twitter" title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/thishostrocks" target="_blank"><i class="fa fa-twitter"></i></a><a rel="nofollow" class="social-icon icon-facebook" title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/thishosting.rocks/" target="_blank"><i class="fa fa-facebook"></i></a><a rel="nofollow" class="social-icon icon-google" title="Follow us on Google+" aria-label="Follow us on Google+" href="https://plus.google.com/107056993232136282396" target="_blank"><i class="fa fa-google"></i></a>
</div></div>
<h2 class="span7 inside site-description">The Best Web Hosting Resources</h2>
<div class="nav-collapse collapse"><div class="menu-main-container"><ul id="menu-main-2" class="nav">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-17"><a href="https://thishosting.rocks/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://thishosting.rocks/category/coupons/">Coupons</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://thishosting.rocks/category/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://thishosting.rocks/category/directory/">Directory</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14"><a href="https://thishosting.rocks/category/knowledgebase/">Knowledgebase</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://thishosting.rocks/category/insider/">Insider</a></li>
</ul></div></div>
<div class="btn-toggle-nav pull-right"><button type="button" class="btn menu-btn" data-toggle="collapse" data-target=".nav-collapse" title="Open the menu" aria-label="Open the menu"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span> </button></div>          			</div>
<!-- /.row-fluid -->
          		</div>
<!-- /.navbar-inner -->
        	</div>
<!-- /.navbar resp -->
      	</div>
<!-- /.navbar-wrapper -->
    	  		</header><div class="row-fluid tc-single-post-thumbnail-wrapper tc-singular-thumbnail-wrapper __before_main_wrapper"><section class="tc-thumbnail span12"><div class=""><a class="tc-rectangular-thumb" href="https://thishosting.rocks/install-docker-on-ubuntu/" title="How to Install Docker on Ubuntu 16.04"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1150x500.jpg" data-webp="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1150x500.jpg.webp" data-srcset-webp="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu.jpg.webp 1150w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-300x130.jpg.webp 300w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-768x334.jpg.webp 768w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1024x445.jpg.webp 1024w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-50x22.jpg.webp 50w" data-srcset-img="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu.jpg 1150w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-300x130.jpg 300w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-768x334.jpg 768w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1024x445.jpg 1024w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-50x22.jpg 50w" data-alt="install docker ubuntu" data-height="500" data-width="1150" data-class="attachment-slider-full tc-thumb-type-thumb wp-post-image wp-post-image" data-sizes="(max-width: 1150px) 100vw, 1150px" class="ewww_webp"><img width="1150" height="500" src="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1150x500.jpg" class="attachment-slider-full tc-thumb-type-thumb wp-post-image wp-post-image" alt="install docker ubuntu" srcset="https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu.jpg 1150w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-300x130.jpg 300w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-768x334.jpg 768w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-1024x445.jpg 1024w, https://thishosting.rocks/wp-content/uploads/2017/05/install-docker-ubuntu-50x22.jpg 50w" sizes="(max-width: 1150px) 100vw, 1150px"></noscript></a></div></section></div>
<div id="main-wrapper" class="container">

    <div class="tc-hot-crumble container" role="navigation"><div class="row"><div class="span12"><div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb">
<span class="trail-begin"><a href="https://thishosting.rocks" title="ThisHosting.Rocks" rel="home" class="trail-begin">ThisHosting.Rocks</a></span> <span class="sep">→</span> <a href="https://thishosting.rocks/category/knowledgebase/" title="Knowledgebase">Knowledgebase</a> <span class="sep">→</span> <span class="trail-end">How to Install Docker on Ubuntu 16.04</span>
</div></div></div></div>
    <div class="container" role="main">
        <div class="row column-content-wrapper">

            
                <div id="content" class="span9 article-container tc-gallery-style">

                    
                        
                                                                                    
                                                                    <article id="post-615" class="row-fluid post-615 post type-post status-publish format-standard has-post-thumbnail hentry category-knowledgebase tag-docker tag-ubuntu"><header class="entry-header"><h1 class="entry-title ">How to Install Docker on Ubuntu 16.04</h1>
<div class="entry-meta">This entry was posted in <a class="btn btn-mini btn-tag" href="https://thishosting.rocks/category/knowledgebase/" title="View all posts in Knowledgebase"> Knowledgebase </a> and tagged <a class="btn btn-mini" href="https://thishosting.rocks/tag/docker/" title="View all posts in docker"> docker </a><a class="btn btn-mini" href="https://thishosting.rocks/tag/ubuntu/" title="View all posts in ubuntu"> ubuntu </a> on <a href="https://thishosting.rocks/2017/05/07/" title="4:04 pm" rel="bookmark"><time class="entry-date updated" datetime="2017-05-07T16:04:32+00:00">May 7, 2017</time></a>  </div>
<hr class="featurette-divider __before_content"></header><section class="entry-content "><p>We’ll show you how to install Docker on your Ubuntu 16.04 server. Short and straight-to-the-point tutorial.</p>
<p>With <a href="https://www.docker.com/">Docker</a>, you can build, ship and run applications inside your server in containers. Essentially, with Docker, you get “virtual machines” inside your virtual machine.</p>
<p><span id="more-615"></span></p>
<h2>Docker requirements</h2>
<p>You can’t run Docker on just about any server. Here are the requirements:</p>
<ul>
<li>64-bit server.</li>
<li>At least 512MB RAM.</li>
<li>Linux Kernel 3.10+. Latest version recommended.</li>
<li>An Ubuntu 16.04 VPS (for the purposes of this tutorial). You can get one from <a href="https://thishosting.rocks/go/vultr/">Vultr</a>, starting from $2.5 a month. Note that you can’t run Docker on an OpenVZ VPS.</li>
</ul>
<h2>Update your server</h2>
<p>Always update your server before doing anything. Run the following command:</p>
<pre>sudo apt-get update &amp;&amp; apt-get upgrade -y</pre>
<h2>Install the latest version of Docker</h2>
<p>If you use Ubuntu’s default repositories, you may not get the latest version of Docker, so to get the latest one, follow the steps below.</p>
<p>Add the key for the official Docker repository to your Ubuntu system:</p>
<pre>sudo apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D</pre>
<p>Add the GPG key to your Ubuntu apt repository:</p>
<pre>sudo apt-add-repository 'deb https://apt.dockerproject.org/repo ubuntu-xenial main'</pre>
<p>Now update your package’s list to get the latest Docker version in your repositories:</p>
<pre>sudo apt-get update</pre>
<p>Run the following command to make sure that you install the latest version of Docker you just added, not the default Ubuntu one:</p>
<pre>apt-cache policy docker-engine</pre>
<p>And now install Docker by running:</p>
<pre>sudo apt-get install docker-engine  -y</pre>
<p>Wait a bit, and that’s it. Docker is officially installed on your Ubuntu 16.04 (64-bit) VPS.</p>
<p>To verify that Docker is installed, run the following command:</p>
<pre>sudo systemctl status docker</pre>
<p>To see which Docker commands you can run, enter this command:</p>
<pre>docker run --help</pre>
<p>Or check the <a href="https://docs.docker.com/engine/reference/commandline/docker/">official documentation</a>.</p>
<p> </p>
<div style="clear: both"></div>
<div style="float: right;position: relative;left: -50%;text-align: left;" class="the_champ_sharing_container the_champ_horizontal_sharing" super-socializer-data-href="https://thishosting.rocks/install-docker-on-ubuntu/">
<div class="the_champ_sharing_title" style="font-weight: bold;list-style: none;position: relative;left: 50%;">Share this</div>
<ul style="list-style: none;position: relative;left: 50%;" class="the_champ_sharing_ul">
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Facebook" title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthishosting.rocks%2Finstall-docker-on-ubuntu%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Twitter" title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=thishostrocks&amp;text=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04&amp;url=https://thishosting.rocks/install-docker-on-ubuntu/")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Reddit" title="Reddit" class="theChampSharing theChampRedditBackground" onclick='theChampPopup("http://reddit.com/submit?url=https://thishosting.rocks/install-docker-on-ubuntu/&amp;title=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04")'><ss style="display:block;" class="theChampSharingSvg theChampRedditSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Google plus" title="Google plus" class="theChampSharing theChampGoogleplusBackground" onclick='theChampPopup("https://plus.google.com/share?url=https://thishosting.rocks/install-docker-on-ubuntu/")'><ss style="display:block;" class="theChampSharingSvg theChampGoogleplusSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Linkedin" title="Linkedin" class="theChampSharing theChampLinkedinBackground" onclick='theChampPopup("http://www.linkedin.com/shareArticle?mini=true&amp;url=https://thishosting.rocks/install-docker-on-ubuntu/&amp;title=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04")'><ss style="display:block;" class="theChampSharingSvg theChampLinkedinSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Pinterest" title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Whatsapp" title="Whatsapp" class="theChampSharing theChampWhatsappBackground"><a href="whatsapp://send?text=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04%20https://thishosting.rocks/install-docker-on-ubuntu/"><ss style="display:block" class="theChampSharingSvg theChampWhatsappSvg"></ss></a></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="WordPress" title="WordPress" class="theChampSharing theChampWordPressBackground" onclick='theChampPopup("//www.addtoany.com/ext/wordpress/press_this?linkurl=https://thishosting.rocks/install-docker-on-ubuntu/&amp;linkname=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04")'><ss style="display:block;" class="theChampSharingSvg theChampWordPressSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" alt="Email" title="Email" class="theChampSharing theChampEmailBackground" onclick="window.location.href = 'mailto:?subject=' + decodeURIComponent('How%20to%20Install%20Docker%20on%20Ubuntu%2016.04' ).replace('&amp;', '%26') + '&amp;body=' + decodeURIComponent('https://thishosting.rocks/install-docker-on-ubuntu/' )"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li>
<li class="theChampSharingRound"><i style="width:70px;height:35px;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://thishosting.rocks/install-docker-on-ubuntu/', 'How%20to%20Install%20Docker%20on%20Ubuntu%2016.04', '')"><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li>
</ul>
<div style="clear:both"></div>
</div>
<div style="clear: both"></div>
<div class="the_champ_sharing_container the_champ_vertical_sharing the_champ_hide_sharing the_champ_bottom_sharing" style="width:44px;left: -10px;top: 100px;-webkit-box-shadow:none;box-shadow:none;" super-socializer-data-href="https://thishosting.rocks/install-docker-on-ubuntu/">
<ul class="the_champ_sharing_ul">
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Facebook" title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthishosting.rocks%2Finstall-docker-on-ubuntu%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Twitter" title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=thishostrocks&amp;text=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04&amp;url=https://thishosting.rocks/install-docker-on-ubuntu/")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Reddit" title="Reddit" class="theChampSharing theChampRedditBackground" onclick='theChampPopup("http://reddit.com/submit?url=https://thishosting.rocks/install-docker-on-ubuntu/&amp;title=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04")'><ss style="display:block;" class="theChampSharingSvg theChampRedditSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Google plus" title="Google plus" class="theChampSharing theChampGoogleplusBackground" onclick='theChampPopup("https://plus.google.com/share?url=https://thishosting.rocks/install-docker-on-ubuntu/")'><ss style="display:block;" class="theChampSharingSvg theChampGoogleplusSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Linkedin" title="Linkedin" class="theChampSharing theChampLinkedinBackground" onclick='theChampPopup("http://www.linkedin.com/shareArticle?mini=true&amp;url=https://thishosting.rocks/install-docker-on-ubuntu/&amp;title=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04")'><ss style="display:block;" class="theChampSharingSvg theChampLinkedinSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Pinterest" title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Whatsapp" title="Whatsapp" class="theChampSharing theChampWhatsappBackground"><a href="whatsapp://send?text=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04%20https://thishosting.rocks/install-docker-on-ubuntu/"><ss style="display:block" class="theChampSharingSvg theChampWhatsappSvg"></ss></a></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="WordPress" title="WordPress" class="theChampSharing theChampWordPressBackground" onclick='theChampPopup("//www.addtoany.com/ext/wordpress/press_this?linkurl=https://thishosting.rocks/install-docker-on-ubuntu/&amp;linkname=How%20to%20Install%20Docker%20on%20Ubuntu%2016.04")'><ss style="display:block;" class="theChampSharingSvg theChampWordPressSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" alt="Email" title="Email" class="theChampSharing theChampEmailBackground" onclick="window.location.href = 'mailto:?subject=' + decodeURIComponent('How%20to%20Install%20Docker%20on%20Ubuntu%2016.04' ).replace('&amp;', '%26') + '&amp;body=' + decodeURIComponent('https://thishosting.rocks/install-docker-on-ubuntu/' )"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li>
<li class=""><i style="width:40px;height:40px;margin:0;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://thishosting.rocks/install-docker-on-ubuntu/', 'How%20to%20Install%20Docker%20on%20Ubuntu%2016.04', '')"><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li>
</ul>
<div style="clear:both"></div>
</div>                                      </section><!-- .entry-content --></article><div id="comments" class="comments-area">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/install-docker-on-ubuntu/#respond" style="display:none;">Cancel reply</a></small>
</h3>			<form action="https://thishosting.rocks/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p>
<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p>
<p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required="true" required="required"></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required="true" required="required"></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200"></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"><input type="hidden" name="comment_post_ID" value="615" id="comment_post_ID"><input type="hidden" name="comment_parent" id="comment_parent" value="0"></p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e0e4c863e2"></p>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="201"></p>			</form>
			</div>
<!-- #respond -->
	</div>
<!-- //#comments .comments-area -->

        
          <hr class="featurette-divider __after_loop">
<nav id="nav-below" class="navigation" role="navigation"><h3 class="assistive-text">
                Post navigation              </h3>

              <ul class="pager">
<li class="previous">
                    <span class="nav-previous">
                      <a href="https://thishosting.rocks/valid-coupons-for-cloudways-2017/" rel="prev"><span class="meta-nav">←</span> Valid coupons for Cloudways [2017]</a>                    </span>
                  </li>
                                              </ul></nav><!-- //#nav-below .navigation -->
</div>
<!--.article-container -->

           
        <div class="span3 right tc-sidebar no-widget-icons">
           <div id="right" class="widget-area" role="complementary">
              <div id="search-4"><form role="search" method="get" id="searchform" class="searchform" action="https://thishosting.rocks/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s"><input type="submit" id="searchsubmit" value="Search">
</div>
			</form></div>
<div id="text-9">Follow us:			<div class="textwidget">
<a href="https://www.facebook.com/thishosting.rocks/"><i class="fa fa-facebook fa-3x" style="padding-right:10px;"></i></a>
<a href="https://twitter.com/thishostrocks"><i class="fa fa-twitter fa-3x" style="padding-right:10px;"></i></a>    
<a href="https://plus.google.com/107056993232136282396"><i class="fa fa-google fa-3x" style="padding-right:10px;"></i></a>
<a href="https://thishosting.rocks/feed/rss/"><i class="fa fa-feed fa-3x"></i></a>
</div>
		</div>
<!-- fixed widget --><div id="text-7">			<div class="textwidget">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><!-- THR Sidebar --><ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6581914980257652" data-ad-slot="4167026528"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
		</div>
<!-- fixed widget --><div id="text-8">Spotlight:			<div class="textwidget"><div class="alert alert-info text-center">
<h3><strong>Great Hosting with Even Greater Support</strong></h3> <p style="text-align:center;">Get web hosting with great 24/7 suport and ultra-fast speed. </p> <a class="btn btn-large btn-success" href="https://thishosting.rocks/go/a2-hosting/" role="button">Go to A2 Hosting</a> <p class="small"><em><a href="https://thishosting.rocks/a2hosting-coupons/">Get a coupon for A2 Hosting</a></em></p>
</div></div>
		</div>            </div>
<!-- //#left or //#right -->
        </div>
<!--.tc-sidebar -->

        
        </div>
<!--.row -->
    </div>
<!-- .container role: main -->

    
</div>
<!-- //#main-wrapper -->

  		<!-- FOOTER -->
  		<footer id="footer" class=""><div class="container footer-widgets  no-widget-icons">
                    <div class="row widget-area" role="complementary">
												
							<div id="footer_one" class="span4">
																
										<aside id="text-2" class="widget widget_text"><h3 class="widget-title">ThisHosting.Rocks</h3>			<div class="textwidget">
<a href="https://thishosting.rocks/about/"><noscript data-img="https://thishosting.rocks/wp-content/uploads/2016/12/thr-inverted.png" data-webp="https://thishosting.rocks/wp-content/uploads/2016/12/thr-inverted.png.webp" data-alt="thishosting.rocks inverted logo" data-style="display: block; margin: 0 auto;" class="ewww_webp"><img style="display: block; margin: 0 auto;" src="https://thishosting.rocks/wp-content/uploads/2016/12/thr-inverted.png" alt="thishosting.rocks inverted logo"></noscript></a> <br>
We are ThisHosting.Rocks. We love hosting providers that rock! You can find a lot of hosting and server-related resources on this site, including: honest, unbiased reviews, expert tutorials, exclusive coupons and more. <br>
2016-2017 © ThisHosting.Rocks</div>
		</aside>
</div>
<!-- .{$key}_widget_class -->

						
							<div id="footer_two" class="span4">
																
										<aside id="text-3" class="widget widget_text"><h3 class="widget-title">THR Support</h3>			<div class="textwidget"><div class="alert alert-success text-center">
<h3 style="color:#005580;"><strong>Need Hosting/Server Support?</strong></h3> <p style="text-align:center;color:#005580;">We are perfect for you, if you want to outsource the support of your web hosting company or if you need server management services. Contact us and get our Expert THR Support Team. </p> <a class="btn btn-large btn-success" href="https://thishosting.rocks/support/" role="button">Get Support</a>
</div></div>
		</aside>
</div>
<!-- .{$key}_widget_class -->

						
							<div id="footer_three" class="span4">
																
										<aside id="nav_menu-3" class="widget widget_nav_menu"><h3 class="widget-title">THR Stuff</h3>
<div class="menu-footer-container"><ul id="menu-footer" class="menu">
<li id="menu-item-56" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56"><a href="https://thishosting.rocks/about/">About</a></li>
<li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57"><a href="https://thishosting.rocks/affiliate-disclosure/">Affiliate Disclosure</a></li>
<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59"><a href="https://thishosting.rocks/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60"><a href="https://thishosting.rocks/tos/">Terms and Conditions</a></li>
<li id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97"><a href="https://thishosting.rocks/submit-coupon/">Submit Coupon</a></li>
<li id="menu-item-239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-239"><a href="https://thishosting.rocks/support">Support</a></li>
<li id="menu-item-58" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58"><a href="https://thishosting.rocks/contact/">Contact us</a></li>
</ul></div></aside><aside id="text-4" class="widget widget_text"><div class="textwidget">
<a href="https://www.facebook.com/thishosting.rocks/"><i class="fa fa-facebook fa-3x" style="padding-right:10px;"></i></a>
<a href="https://twitter.com/thishostrocks"><i class="fa fa-twitter fa-3x" style="padding-right:10px;"></i></a>    
<a href="https://plus.google.com/107056993232136282396"><i class="fa fa-google fa-3x" style="padding-right:10px;"></i></a>
<a href="https://thishosting.rocks/feed/rss/"><i class="fa fa-feed fa-3x"></i></a>
</div>
		</aside>
</div>
<!-- .{$key}_widget_class -->

																	</div>
<!-- .row.widget-area -->
				</div>
<!--.footer-widgets -->
				    	   		</footer>
</div>
<!-- //#tc-page-wrapper -->
			<style type="text/css">

		@media (min-width: 820px) {
			#review-statistics .review-wrap-up .review-wu-left .rev-wu-image, #review-statistics .review-wrap-up .review-wu-left .review-wu-grade {
				height: 190px;
			}

			#review-statistics .review-wrap-up .review-wu-left .review-wu-grade .cwp-review-chart .cwp-review-percentage {

				margin-top: 18%;
			}

			#review-statistics .review-wrap-up .review-wu-left .review-wu-grade .cwp-review-chart span {
				font-size: 39px;
			}

		
		}

		#review-statistics .review-wrap-up div.cwpr-review-top {
			border-top: 5px solid #3BAEDA;
		}

		.user-comments-grades .comment-meta-grade-bar,
		#review-statistics .review-wu-bars ul li {
			background: #E1E2E0;
		}

		#review-statistics .rev-option.customBarIcon ul li {
			color: #E1E2E0;
		}

		#review-statistics .review-wrap-up .review-wu-right ul li, #review-statistics .review-wu-bars h3, .review-wu-bars span, #review-statistics .review-wrap-up .cwpr-review-top .cwp-item-category a {
			color: #3D3D3D;
		}

		#review-statistics .review-wrap-up .review-wu-right .pros h2 {
			color: #8DC153;
		}

		#review-statistics .review-wrap-up .review-wu-right .cons h2 {
			color: #C15353;
		}

		div.affiliate-button a {
			border: 2px solid #3BAEDA;
		}

		div.affiliate-button a:hover {
			border: 2px solid #3BAEDA;
		}

		div.affiliate-button a {
			background: #ffffff;
		}

		div.affiliate-button a:hover {
			background: #3BAEDA;
		}

		div.affiliate-button a span {
			color: #3BAEDA;
		}

		div.affiliate-button a:hover span {
			color: #FFFFFF;
		}

				div.affiliate-button a span {
			background: url("https://thishosting.rocks/wp-content/plugins/wp-product-review/images/cart-icon.png") no-repeat left center;
		}

		div.affiliate-button a:hover span {
			background: url("https://thishosting.rocks/wp-content/plugins/wp-product-review/images/cart-icon-hover.png") no-repeat left center;
		}

		
				.commentlist .comment-body p {
			clear: left;
		}

			</style>
<script type="text/javascript">
		var c1 = "#FF7F66";
		var c2 = "#FFCE55";
		var c3 = "#50C1E9";
		var c4 = "#8DC153";
	</script><div id="fb-root"></div>
	<script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/akismet/_inc/form.js?ver=3.3.1"></script><link rel="stylesheet" id="coupon-popup-css" href="https://thishosting.rocks/wp-content/plugins/coupon-popup/css/coupon-popup.css?ver=4.7.4" type="text/css" media="all">
<link rel="stylesheet" id="vex-css" href="https://thishosting.rocks/wp-content/plugins/coupon-popup/css/vex.css?ver=4.7.4" type="text/css" media="all">
<script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20"></script><script type="text/javascript">
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/comment-reply.min.js?ver=4.7.4"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/modernizr.min.js?ver=3.5.12"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/themes/customizr/inc/assets/js/retina.min.js?ver=3.5.12"></script><script type="text/javascript">
var q2w3_sidebar_options = new Array();
q2w3_sidebar_options[0] = { "sidebar" : "cs-2", "margin_top" : 10, "margin_bottom" : 0, "stop_id" : "footer", "screen_max_width" : 0, "screen_max_height" : 0, "width_inherit" : true, "refresh_interval" : 1500, "window_load_hook" : false, "disable_mo_api" : false, "widgets" : ['text-7','text-8'] };
</script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.0.4"></script><script type="text/javascript" src="https://thishosting.rocks/wp-content/plugins/super-socializer/js/front/combined.js?ver=7.8.20"></script><script type="text/javascript" src="https://thishosting.rocks/wp-includes/js/wp-embed.min.js?ver=4.7.4"></script>
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 2376/2437 objects using memcached
Page Caching using disk: enhanced
Database Caching 13/30 queries in 0.006 seconds using memcached

 Served from: thishosting.rocks @ 2017-05-08 09:22:32 by W3 Total Cache -->